そろそろ BrunchFirefox 4 に対応する 準備をしようか、まじめにコードと資料を整理し直そうかと迷っていたら、 どんどん時間だけが過ぎていくので、ひとまず今のコードが Firefox 4 で 動くかどうか確認してみたところ動きました。
# Beta6 日本語版 で確認しました。

 ところが機能的には問題なさそうなんですけど、 設定ダイアログを出してみたら、バージョンが表示されてないことに気づきました。  たいした問題ではないのですが、 Firefox 4 の リリースも 遅れるみたい だし、 互換性の問題かバグかも判別つかないので、 もうちょっと気張ってみようと思います。

 Firefox 4 で Brunch を 使う場合、ひとまず install.rdf の
        3.6.*
となっているところを
        4.0.*
と書き換えてお使いください m(_ _)m

「 Firefox 4 のリリース、 2011 年に延期」ITmedia より)