オープンソースソフトウェアとかウェブ技術とか 「 Ubuntu 10.10 で Sass/Compass を使う(環境設定編)」

 Sassy CSS(SCSS) を使ってみたく ruby も知らない haml も知らない輩が、 先般、チャレンジした わけですが 見事に玉砕。
 何が悪いんだろうと、sass の チュートリアル(むろん 日本語訳 )を 熟読してみると SCSS のサポートは Sass 3.0 から サポートされた機能だと言うことに気がつきました。
sass -v
などしてみると表示されているのは 2.x 。
これか!と一瞬、どや顔になってアップデートを試みるも、 何度アップデートかけても最新版がインストールされているような表示がされます。
 で、しつこく調べた結果、当たったのが 上記の ドキュメント
 OS (Ubuntu) のせい やったんかい! orz

 Ubuntu 10.04LTS で rubyhaml を ( apt-get で) インストールしたどこかの時点で /usr/bin 以下に haml/sass のバイナリがあり、 gem でインストールされる haml /sass は /var/lib/gems/1.8/bin 以下にあったというオチ orz
 実際、最新 sass で てきとーにつくった SCSS ファイルをコンパイルしてみると…できるじゃな~い (^^)b

 ということで、ちょうど最近、Ellinikonblue.com 側の トップページを書き直そうとしていて、 その CSS を SCSS から書いているのですが、これがすごい。
 何がすごいって見渡せば、すぐに何が書いてあるかわかる。 伝わらないかも知れないですが、個人的には文明開化級のインパクトです… が、その話は成果諸共また後日。今回はトラブル解決まで。